Disturbance in service

Incident Report for nShift TMS

Update

Update: Intermittent latency may still occur. Stabilization efforts will continue through the evening, and we expect the service to return to normal performance by tomorrow. Updates will be shared if there are significant changes.
Posted Apr 27, 2026 - 18:15 CEST

Update

Update: Performance degradation persists, with slow page loads at times. The service remains operational, but retries may be required under high load. Improvement is expected as load decreases and mitigation work progresses.
Posted Apr 27, 2026 - 14:27 CEST

Identified

Update: The issue has been identified and we are actively working to restore full functionality. Some performance degradation is expected to continue while this work is ongoing, potentially until tomorrow.
Posted Apr 27, 2026 - 10:43 CEST

Investigating

We are experiencing performance degradation across the service, leading to slower response times. We are actively investigating. Updates to follow
Posted Apr 27, 2026 - 09:32 CEST
This incident affects: nShift TMS, Web-TA, Memnon Apport, DHL Multishipping, and Frigoscandia TA-Connect.